Results 1 to 5 of 5

Thread: I found this growing in the viv ...

  1. #1
    Junior Member
    Join Date
    Jul 2014
    Nationality
    [Mexico]
    Posts
    20

    Default I found this growing in the viv ...

    i was doing some maintennace for the viv, and i found this growing in the viv and this kind of green slime at bottom, i have to mention that my viv has a false water bottom made with zoo med's waterfall kit, the viv is next to a window and it takes sunlight all the day ...


    So what this can be? green mold? is this safe?


    BTW i have a RETF ..... and is pretty healthy till now ...


    Attachment 78940

    Attachment 78942
    Attached Images Attached Images   

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Posts
    Many
     

  3. #2
    100+ Post Member elly's Avatar
    Join Date
    Sep 2014
    Nationality
    [United States]
    Posts
    1,589
    Picture Albums: Member Photo Albums

    Default Re: I found this growing in the viv ...

    Some kind of slime mold would be my guess. It should be harmless and will probably disappear soon. You might want to check your tank temp and humidity and see if they're within a good range.

    Also you said your frog used to be healthy? Did it get sick?

  4. #3
    Junior Member
    Join Date
    Jul 2014
    Nationality
    [Mexico]
    Posts
    20

    Default Re: I found this growing in the viv ...

    the humidity is fine, in fact sometimes is a little low but never been above the good range, the frog is very healthy, never got sick, is eating the normal, i left some crickets in a glass bowl and some others loose to be hunted by the frog

  5. #4
    100+ Post Member elly's Avatar
    Join Date
    Sep 2014
    Nationality
    [United States]
    Posts
    1,589
    Picture Albums: Member Photo Albums

    Default Re: I found this growing in the viv ...

    I wouldn't worry about it. Everything I read says that slime mold is fairly harmless.

  6. #5
    Junior Member
    Join Date
    Jul 2014
    Nationality
    [Mexico]
    Posts
    20

    Default Re: I found this growing in the viv ...

    Quote Originally Posted by elly View Post
    I wouldn't worry about it. Everything I read says that slime mold is fairly harmless.


    Thank you very much !!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Growing
    By Tyrrell187 in forum African Bullfrogs
    Replies: 1
    Last Post: November 13th, 2016, 06:16 PM
  2. growing up!
    By elura in forum Vivarium, Terrarium & Enclosure Discussion
    Replies: 2
    Last Post: July 13th, 2013, 05:54 AM
  3. How do you keep moss alive and growing ? store bought or wild found ?
    By jetoutant in forum Vivarium, Terrarium & Enclosure Discussion
    Replies: 2
    Last Post: March 9th, 2012, 09:57 PM
  4. "Comet" Growing , growing , grown !
    By flybyferns in forum Tree Frogs
    Replies: 1
    Last Post: January 29th, 2012, 07:30 AM
  5. Growing
    By puck in forum Pacman Frogs
    Replies: 9
    Last Post: October 2nd, 2010, 01:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •